Migrating Windows 7 OS From Hard Disk To Raid 0 SSDs

Raid 0 SSDs for System, Hard disk for data

I had recently assembled my work PC based on the new AMD processor, the FX 8120 and also managed to solve the problem of Task Manager showing only four cores instead of eight cores. My intention to have the OS installed on an SSD was dashed when the 64GB Plextor SSD failed to work. Not wanting to be discouraged by the setback, I carried-on assembling the PC, install Windows 7 Home Premium, activate and update it. I was never worried if there would be problems in migrating the OS later on when I got the SSD back after RMA. This was because I thought I could just easily clone the new SSD with the saved clone image. I was wrong because I had a change of plan.

I was getting more ambitious. Instead of waiting for the 64GB Plextor SSD repaired or replaced, I had gotten myself two 60GB ADATA SSDs and another 8GB of ram (16GB total, Pagefile set to None). I had opted for a Raid 0 configured SSDs but unfortunately or fortunately (at least I learnt something) I came to realise one unforseen problem. Clonezilla could not recognised Raid configuration. Thus I began searching for a freeware progam that would do the job and after some searching and reading, I settled for EaseUS® Todo Backup Free. It was a Windows application program that needed to be installed and not a standalone program that booted from a CD or USB flash drive, nevertheless it did the job well. I reimaged the hard disk partition with the first clone image that I had saved (usually I clone twice, one after activation and update and another after fully installed with the required apps). Next, EaseUS Todo Backup Free was installed and with it I did a partition to partition cloning from the harddisk to the striped SSDs. I was able to boot Windows 7 on the striped SSDs straightaway after completion. No problem encountered.

Since the partition size on the hard disk was 100GB and the size of the striped SSD was 120GB, some space on the striped SSDs became unallocated. GParted was used to do the resizing of the partition and to claim back the unused space (Note: In general, cloning is only possible if the target partition is bigger than the source partition). After recovering the space I was still able to boot Windows 7 flawlessly. There was also a small unused space of a few megabytes at the beginning of the partition, I recovered this space too but then Windows 7 could not boot. My first attempt at repairing the boot problem with Windows 7 installation disc (selecting Startup Repair) was unsuccessful. On my second attempt I loaded the AHCI driver and it worked even though I got a message saying that the loading of the driver had failed. Ever since that second attempt the PC was running fine.

The striped SSDs was then immediately cloned using Windows 7 very own Backup and Restore and I had created a System Repair Disc as a companion just in case Windows could not boot. Eventually, as been my habit, after a full install of all the programs that I needed, a second clone image was made. Now I wonder if Windows Backup and Restore could be used for migrating the OS in the first place. Never did I try it before but it seems to look possible.

Windows 7 running off hard disk

Windows 7 runnig off Raid 0 SSDs

Here’s a peek at the desktop. All shortcuts of alike programs were placed in a single folder and represented by a single RocketDock icon as can be seen here, one for CAD programs and another for image processing programs.

The desktop showing the main programs

Note: I am just making an assumption here. I have a feeling that the 6 SATA 3.0 ports on the Gigabyte motherboard with AMD 970 chipset being multiplied from a single channel. The speed of the striped SSDs is about the same speed as the speed of a single SSD if not slightly lower (comparing Passmark results). It seems that I need a true 2 channels Raid 0 controller card on at least two lanes PCIe (x2) card to get higher throughput. The HighPoint RocketRAID 640 PCIe x4 looks like a likely candidate.

Update 27 Dec 2011

System now running at 3.5GHz and after installing the AMD AHCI compatible SATA Raid Driver found in RAIDXpert 11-12 (did not install RAIDXpert), disk performance improved further.

Better disk performance after installating AHCI compatible SATA RAID Driver

Advertisements

6 Responses to “Migrating Windows 7 OS From Hard Disk To Raid 0 SSDs”

  1. Ray Says:

    Hi there,

    great post, im having exactly the same issue in migrating to an SSD raid 0 configuration.

    im about to you the free to backup program and will hopefully have good news to report afterwards

  2. Ray Says:

    The migration worked a treat, however SSD performance only improved slightly on the windows experience index from 5.8 to 6.1, i will have to find a few tweeks to improve it further.

    however i am getting read speeds of around 527MB/s, when testing using Aida64

    Old HDD:
    WD Velociraptor 150GB @ 10,000 rpm
    aida 64 read speeds around 110MB/s

    SSD’s used are:

    2 x intel 520s 60Gb configured as raid 0

    intel specs of data transfer says:
    Sequential Read – 550 MB/s,
    Sequential Write – 475 MB/s,

    • asahjaya Says:

      Thanks again for the info. I guess it is the motherboard chipset throughput for the raid that let it down. That is why I am looking for a PCIe x4 raid controller solution. I still have not tried it yet, just could not get it locally.


Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: